Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
news [2016/02/26]
terence
news [2016/07/05] (current)
terence [July 5, 2016]
Line 1: Line 1:
 ====== News ====== ====== News ======
 +
 +===== July 5, 2016 =====
 +
 +I've released a new project to the public, [[:​projects:​observer_template]].
 +
 +This one I created in 2012, and finally released it (now) in 2016.
 +
 +Also, updated [[:​projects:​singleton_template]] to remove the namespace and going back to the original naming convention '​tSingleton'​ that I was originally using
 +
 +===== June 28, 2016 =====
 +
 +[[:​projects:​backuptool_for_dokuwiki]] has been updated. Apparently a new release of DokuWiki, their version 2016-06-26, broke the existing plugin. Luckily a user on github, **dsp777**, was able to come up with a fix for it; so the issue should be resolved, and thanks, **dsp777**.
  
 ===== February 26, 2016 ===== ===== February 26, 2016 =====
  
-Some code updates to [[:​projects:​endian_template]],​ based on feedback from the two reddit threads ([[http://tjgrant.com/wiki/projects:​endian_template|/​r/​programming thread]], [[http://tjgrant.com/wiki/projects:​endian_template|/r/cpp thread]]), resulted in some good updates:+Some code updates to [[:​projects:​endian_template]],​ based on feedback from the two reddit threads ([[https://www.reddit.com/r/​programming/​comments/​47ebe4/​endian_template_c_work_with_endian_types_in_c/​|/​r/​programming thread]], [[https://www.reddit.com/r/​cpp/​comments/​47e9e2/​endian_template_c_work_with_endian_types_in_c/|/r/cpp thread]]), resulted in some good updates:
  
   * Renamed typedefs without ''​_t''​ postfix notation as this appears to be "​reserved"​ by POSIX (thanks to reddit user "​doodle77"​)   * Renamed typedefs without ''​_t''​ postfix notation as this appears to be "​reserved"​ by POSIX (thanks to reddit user "​doodle77"​)
Line 9: Line 21:
   * Changed endian testing method to use reinterpret_cast,​ as the previous was using "type punning",​ which in theory can have undefined behavior (thanks to reddit user "​NasenSpray"​)   * Changed endian testing method to use reinterpret_cast,​ as the previous was using "type punning",​ which in theory can have undefined behavior (thanks to reddit user "​NasenSpray"​)
   * Removed ::PassThru method as a small optimization   * Removed ::PassThru method as a small optimization
- 
 ===== February 23, 2016 ===== ===== February 23, 2016 =====
  
Print/export
QR Code
QR Code News (generated for current page)